Category: MAGNA Q & A

  • MAGNA3- FAQ’s

    MAGNA3- FAQ’s
  • Magna 3 Q&A – Surging Pump?

    Magna 3 Q&A – Surging Pump?

    Question: I have a Magna 3 that often surges and cannot figure out what is the cause? Answer: The most common reason for a Magna surging is do to the pump being incorrectly wired. Check to see if the power is being cycled on and off. As shown in the diagram below, the motor is […]

  • Magna 3 Q&A – GPM readout Accuracy?

    Magna 3 Q&A – GPM readout Accuracy?

    Question: How accurate is the GPM readout on the Magna display? Answer: For most applications, it is accurate to the actual flow. However, if the duty point is far to the left or right of the pump curve, it will diminish. In this case, there can be a 5%-10% differential between actual flow. In a […]

  • Magna 3 Q&A: FLANGE KITS

    Magna 3 Q&A: FLANGE KITS

    Question: What flange kits fit the multiple Magna models? Answer: Below is a list of both the cast iron and bronze Magna flange kits:

  • Magna 3 Q&A- BACNet ON/OFF Option

    Magna 3 Q&A- BACNet ON/OFF Option

    Question: Can I set up start/stop on a Magna 3 through a BACnet CIM card rather than hard wire directly to the pump? Answer: Yes, the Binary Outputs can be changed to allow Bus on and off control. The BO, 0 sets the control source. Set to “1” to enable control via BUS Control and […]

  • Magna 3 Q&A – BTU Metering via Delta T control?

    Magna 3 Q&A – BTU Metering via Delta T control?

    Question: I run a housing development and want to set up Magna’s for estimating (non-billable) BTU monitoring. Can this be done with these pumps through a Delta T option? Answer: Yes, it can be in Differential Temperature control mode. The pump should piped on the supply side using the built in sensor. It is accomplished […]

  • MAGNA 3 Q&A – Sensor Replacement?

    MAGNA 3 Q&A – Sensor Replacement?

    Question: I need to replace the external sensor on a Magna, can I repair it and how do I replace it? Answer: If the sensor (P/N 97471249) is malfunctioning, it is most likely due to being contaminated and not defective. If it was defective, it would not work as soon as the pump was installed. […]